Contents

Introduction ...........................................................................................................2
Omega MP main features: ................................................................................ 2
Getting Started ..................................................................................................3
Assumptions .......................................................................................................3
1. Setting up The Host Arduino ........................................................................ 3
2. Connecting the Omega MP Shield ...............................................................4
Usage ...................................................................................................................5
Using the on-board sockets - Inserting the MCU ...............................................5
  Configuration for On-board MCUs ..................................................................5
Using In Circuit Serial Programming (ICSP/ISP) .............................................6
  6-pin Header 10-pin Header .............................................................................6
  Configuration for ICSP ...................................................................................6
Alternate Connectivity ......................................................................................7
  To initiate programming ...............................................................................8
  Using With Other Programming Software ...................................................8
On board status, control and configuration .....................................................9
Specifications ...................................................................................................10
  Power Requirements .....................................................................................10
  Supported Devices .........................................................................................10
  Physical .........................................................................................................10
Introduction

The Omega MCU Systems Omega MP shield is designed to work in conjunction with an Arduino UNO, Duemilanove or 100% compatible MCU development board and the ArduinoISP sketch to emulate an AVRISP provide robust and reliable AVR programming capabilities. It offers direct on-board means to program a variety of popular 28, 20 and 8 pin MCUs. In addition it has both 6-pin and 10-pin ICSP headers to enable it to be used with almost any AVR chip that offers an ICSP programming option whether in circuit (circuit must allow for this) or on a solderless breadboard.

Omega MP main features:
• Tough 1.6mm FR4 PCB
• Ability to burn Arduino bootloaders
• Program without a bootloader for increased program space
• Program almost any AVR MCU that uses ICSP
• Dual on-board ZIF sockets directly support:
  o ATmega328, ATmega168, ATmega88, ATmega48, ATmega8
  o ATtiny4313, ATtiny2313
  o ATtiny85, ATtiny45, ATtiny25, ATtiny13
• 6-pin and 10-pin ICSP headers provided to allow programming in circuit and on solderless breadboards
• Jumper configurable external crystal oscillator
• 16MHz crystal
• Jumper configurable reset disable
• Jumper configurable target device supply voltage for ICSP/ISP
• LED status for Power, Heartbeat, Error and Activity
• Compatible with both the ArduinoIDE and with avrdude
Getting Started

Assumptions
This document assumes the following.

- The user is familiar with the basic concepts of running and programming an Arduino or compatible board and the Arduino IDE.
- The use of Arduino IDE version 1.0 or later
- The user can update Arduino cores and the file 'boards.txt' and, if desired, has chosen and configured one of the many ATtiny cores that are available.

1. Setting up The Host Arduino
   a) Connect your Arduino UNO, Duemilanove or 100% compatible board to your computer as you normally do to program it with a sketch. Make sure there is nothing else attached to your Arduino.
   b) Start the Arduino IDE. If the IDE not already set to program your board, set it up appropriately.
   c) From the “Files > Examples” menu Select ArduinoISP
   d) Upload the ArduinoISP sketch to your board.
e) Remove the board from your computer and from power after the sketch had been uploaded.

2. Connecting the Omega MP Shield
The Omega MP is equipped with a standard shield base header set. It is compatible with both the older Arduino shield base and the newer R3 shield base. The following pictures show how to align the Omega MP shield correctly on each type of shield base.

Once properly aligned, gently push the shield into the base until it is seated fully and reconnect to the USB and power to the host Arduino (see below). The PWR LED should light and the ACTIVITY, ERROR and HRTBT LEDs should flash in order, then the HRTBT LED should begin to pulse.

At this point you are ready to begin downloading programs (sketches) or bootloaders to your MCU.
Usage

Using the on-board sockets - Inserting the MCU
In order to reduce wear and tear on your microcontroller chips and increase usability and accessibility, the Omega MP is equipped with a zero insertion force (ZIF) sockets. To place an MCU into a socket make sure the chip into the socket as shown with its pin-1 adjacent to the lever. Steady the board and lower the ZIF socket lever to just past horizontal into the locked position. This will clamp the microcontroller into place. Removal of the chip is achieved by returning the lever to the vertical position.

Configuration for On-board MCUs

<table>
<thead>
<tr>
<th>MCU</th>
<th>Socket</th>
<th>Internal Oscillator</th>
<th>External Crystal</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATmega8</td>
<td>28-pin</td>
<td>J1, J2 – OFF</td>
<td>J1, J2 – ON</td>
</tr>
<tr>
<td>ATmega48</td>
<td></td>
<td>J3 – GND</td>
<td>J3 – GND</td>
</tr>
<tr>
<td>ATmega88</td>
<td></td>
<td>Tvcc – Don’t Care</td>
<td>Tvcc – Don’t Care</td>
</tr>
<tr>
<td>ATmega168</td>
<td></td>
<td>RSD – ON (usually)</td>
<td>RSD – ON (usually)</td>
</tr>
<tr>
<td>ATmega328</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ATtiny2313</td>
<td>20-pin</td>
<td>J1, J2 – OFF</td>
<td>J1, J2 – ON</td>
</tr>
<tr>
<td>ATtiny4313</td>
<td></td>
<td>J3 – OFF</td>
<td>J3 – OSC2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Tvcc – Don’t Care</td>
<td>Tvcc – Don’t Care</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RSD – ON (usually)</td>
<td>RSD – ON (usually)</td>
</tr>
<tr>
<td>ATtiny13</td>
<td>20-pin</td>
<td>J1, J2 – OFF</td>
<td>J1, J2 – ON</td>
</tr>
<tr>
<td>ATtiny25</td>
<td></td>
<td>J3 – GND</td>
<td>J3 – OSC2</td>
</tr>
<tr>
<td>ATtiny45</td>
<td></td>
<td>Tvcc – Don’t Care</td>
<td>Tvcc – Don’t Care</td>
</tr>
<tr>
<td>ATtiny85</td>
<td></td>
<td>RSD – ON (usually)</td>
<td>RSD – ON (usually)</td>
</tr>
<tr>
<td>ATtiny13</td>
<td>20-pin</td>
<td>J1, J2 – OFF</td>
<td>Not Supported</td>
</tr>
<tr>
<td>ATtiny25</td>
<td></td>
<td>J3 – GND</td>
<td>(too few I/O pins – if needed, use</td>
</tr>
<tr>
<td>ATtiny45</td>
<td></td>
<td>Tvcc – Don’t Care</td>
<td>solderless breadboard method)</td>
</tr>
<tr>
<td>ATtiny85</td>
<td></td>
<td>RSD – ON (usually)</td>
<td></td>
</tr>
</tbody>
</table>

Keep in mind that only one device can be programmed by the Omega MP shield at a time. This means you cannot program with an MCU in each socket, and you cannot program with an MCU in a socket while you are using one of the ICSP headers, and only one ICP header can be used at a time. Also, 8-pin devices that are supported by the on-board sockets are placed in the 20-pin socket with pin-1 of the MCU in pin-1 of the socket (adjacent to the lever) as shown.
Using In Circuit Serial Programming (ICSP/ISP)

ICSP, or ISP (In System Programming) is a method by which an MCU (an AVR in this case) can be directly programmed while still in a circuit. In the AVR world, the programmer is known as the master and the target as the slave. The signals used are MOSI (Master Out – Slave In), MISO (Master In – Slave Out) and SCK (Serial Clock) which is supplied by the master, or programmer. Add to this a reset line from the master, to ready the MCU for data transfer, Tvcc by which the master can power the target MCU, and a ground and you have all the signals of a standard AVR ISP interface. The Omega MP shield provides both standard pin-out 6-pin and 10-pin ICSP headers. These can be used to program an MCU directly. Since the ICSP protocol is built into most Atmega chips it is not dependant on using a bootloader and does not require the serial interface.

<table>
<thead>
<tr>
<th>6-pin Header</th>
<th>10-pin Header</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>Function</td>
</tr>
<tr>
<td>1</td>
<td>MISO</td>
</tr>
<tr>
<td>2</td>
<td>Tvcc</td>
</tr>
<tr>
<td>3</td>
<td>SCK</td>
</tr>
<tr>
<td>4</td>
<td>MOSI</td>
</tr>
<tr>
<td>5</td>
<td>Reset</td>
</tr>
<tr>
<td>6</td>
<td>GND</td>
</tr>
<tr>
<td>7</td>
<td>SCK</td>
</tr>
<tr>
<td>8</td>
<td>GND</td>
</tr>
<tr>
<td>9</td>
<td>MISO</td>
</tr>
<tr>
<td>10</td>
<td>GND</td>
</tr>
</tbody>
</table>

When connecting the cable, ensure pin-1 on the Omega MP shield ICSP header goes to pin-1 on the target ICSP header.

Configuration for ICSP

<table>
<thead>
<tr>
<th>Option</th>
<th>Tvcc</th>
<th>RSD</th>
<th>J1</th>
<th>J2</th>
<th>J3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power to target</td>
<td>ON</td>
<td>ON</td>
<td>Don’t Care</td>
<td>Don’t Care</td>
<td>Don’t Care</td>
</tr>
<tr>
<td>No power to target</td>
<td>OFF</td>
<td>ON</td>
<td>Don’t Care</td>
<td>Don’t Care</td>
<td>Don’t Care</td>
</tr>
</tbody>
</table>
Alternate Connectivity
Should there be a need to program a device that is not supported in the sockets of the Omega MP shield and that does not have an ICSP header, jumpers and a solderless breadboard can often be used. The picture below shows the Omega MP shield being used to program a small Omega Mini-328 (Arduino Mini compatible device) using this method. The key is to correctly connect the ICSP signals, ground and Tvcc, as required.

Remember, if you are using a breadboard circuit to build your prototype project keep in mind that the ground of the Omega MP shield will always need to be properly connected to the off-board circuit’s ground when programming to ensure a good voltage reference and a suitable return path for the data signals. This is regardless to whether Tvcc is being supplied to the target or not. Failure to provide a proper ground may result in some very strange and difficult to diagnose behavior of the combined circuit.

Also, it is worthy to note that, if the ICSP signals of the MCU are being used by the prototype for other than ICSP purposes, I/O circuitry for instance, this additional circuitry may interfere with the programming signals and cause the programming to fail. In these cases some method will have to be arranged to remove any attached circuitry temporarily to enable programming.
To initiate programming

In this section the host Arduino is the Arduino or 100% compatible that has the Omega MP shield and is running ArduinoISP. The target is the board, device or chip to be programmed.

If using the Arduino IDE to burn a bootloader
   a. Set board under ‘Tools > Board’ to whatever the board or target is, or a board whose bootloader you want to use and that is compatible with the target device.
   b. Set programmer under ‘Tools > Programmer’ to ‘Arduino as ISP’
   c. To burn the bootloader select ‘Tools > Burn Bootloader’

If using the Arduino IDE to program code
   a. Set board under ‘Tools > Board’ to whatever the board or target is.
   b. Set programmer under ‘Tools > Programmer’ to ‘Arduino as ISP’
   c. Load the sketch you wish to program into the MCU
   d. To upload the code select ‘File > Upload Using Programmer’ or press ‘Ctrl+Shift+U’

If using avrdude to burn a hex file
   a. Refer to the avrdude documentation
   b. You must specify the virtual com port that the host Arduino running ArduinoISP is using
   c. You must specify avrisp as the programmer
   d. You must set the baud rate to 19200
   e. The following command line will burn a hex file containing the
      Duemilanove bootloader onto a Atmega328P with the host Arduino on com4 running ArduinoISP

```
avrdude -P com4 -b 19200 -p m328p -c avrisp -Ulock:w:0x0F:m -Uhfuse:w:0xDA:m -Ulfuse:w:0xFF:m -Uefuse:w:0x05:m -V -Uflash:w:ATmegaBOOT_168_atmega328.hex:i –u
```

Using With Other Programming Software
Generally, any programming software that will work with the avrisp programmer at 19200 baud will work with an Arduino with an omega MP shield running the ArduinoISP sketch.
### On board status, control and configuration

<table>
<thead>
<tr>
<th>LED</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PWR</td>
<td>The green PWR LED indicates that power is applied when lit.</td>
</tr>
<tr>
<td>ACIVITY</td>
<td>The blue ACIVITY LED indicates that programming is underway</td>
</tr>
<tr>
<td>ERROR</td>
<td>The red ERROR LED indicates that an error has occurred during programming. Check the Arduino IDE or avrdude output for error messages.</td>
</tr>
<tr>
<td>HRTBT</td>
<td>The yellow HRTBT LED indicates that the ArduinoISP sketch is active and running. If this stops, reset the host Arduino and try again, or re-load the ArduinoISP sketch.</td>
</tr>
<tr>
<td>J1, J2</td>
<td>J1 and J2 connect the external crystal. If they are removed, the crystal is no longer connected to either socket.</td>
</tr>
<tr>
<td>OSC2, GND</td>
<td>J3 determines what is connected to pin- of the 20-pin ZIF socket. Use the OSC2 position if you wish to use an external crystal with an ATtiny2313 or ATtiny4313. Use the GND position for the supported 8-pin MCUs.</td>
</tr>
<tr>
<td>TVCC</td>
<td>When in place, 5V is supplied to the TVcc pin of the ICSP headers. Remove this jumper if the target device is powered from another source.</td>
</tr>
<tr>
<td>RST</td>
<td>When in place, automatic reset of the host Arduino is disabled. This is the default and most common configuration. Remove this jumper if the host requires the reset signal.</td>
</tr>
</tbody>
</table>
Specifications

Power Requirements

- Supply Voltage: 5V DC
- Supply Current: Typically between 3mA and 12mA no MCU and not connected to an ICSP target

Supported Devices

Devices supported by the hardware:
- Via on-board sockets
  - ATmega8, ATmega48, ATmega88, ATmega168, ATmega328
  - ATtiny2313, ATtiny4313
  - ATtiny13, ATtiny25, ATtiny45, ATtiny85
- Via ICSP
  - Any Atmel AVR device that supports low voltage ICSP programming

Programming software support for devices is dependant on the software. Please check the documentation for the software you intend to use.

Physical

- Length: 62mm
- Width: 52mm
- Height: 21mm
- Weight: 39g
- Operating Temp. 0°C – 85°C

Note: Arduino is a trademark of the Arduino project team.